Get Firefox Add-ons to Work with ALL Versions of Firefox

The way you feel when you realize your favorite add-on is incompatibleEver upgraded to the next version of Firefox and your add-on didn’t show up because it was marked “Not Compatible”? There is a very simple way to force your version of Firefox to accept the add-on even if it isn’t compatible.

There are a few reasons why your installed add-ons might get marked as incompatible. Sometimes the developer has not changed the install requirements to accept your version. Mozilla suggests to developers that they don’t mark it compatible until they KNOW it is compatible. So, many developers don’t mark their add-ons compatible with beta and alpha releases of Firefox. Another reason an add-on might not be marked as compatible is because it really ISN’T compatible. Running an incompatible add-on can corrupt data in your browser profile and other places on your computer so don’t force add-ons to work unless you are willing to deal with the risks.

all_three

Continue reading Get Firefox Add-ons to Work with ALL Versions of Firefox